top of page

I WILL BE LEADING WORSHIP AT CALVARY CHRISTIAN FELLOWSHIP Group

Public·18 members
Paul Samsonov
Paul Samsonov

Intel 3945 Wifi Drivers For Mac



There are many tools and approaches available on the web for WEP cracking, and one can get easily lost and confused when reading all the information provided on discussion forums (OmniPeek, WinAirCrack, airmon, aircrack, Kismet, mac driver, ipwraw driver, ilw3945, etc.). The first question that needs to be answered is which platform to use. Some have had success with Windows XP. We have not seen anyone having success WEP cracking with Windows Vista. It is advised to attempt WEP cracking with Linux (we used UBUNTU). This is for one major reason. Since Linux is open source, it is much easier to find or develop Wi-Fi drivers for your Intel PRO/Wireless 3945ABG network adapter to get access the needed functionalities.




Intel 3945 Wifi Drivers For Mac



When searching web, you can find information about endless number of drivers for the Intel PRO/Wireless 3945ABG adapter, such as mac80211, IEEE80211, ipwraw, iwl3945, ipw3945, iwlwifi, madwifi, serialmonkey driver, driver from tinyshell.be, wildpacket driver, and many others. Installing and/or patching them may not be very easy.


Navigation: Linux Kernel Driver DataBase - web LKDDB: Main index - I index CONFIG_IWL4965: Intel Wireless WiFi 4965AGN (iwl4965)(adsbygoogle = window.adsbygoogle []).push();General informationsThe Linux kernel configuration item CONFIG_IWL4965 has multiple definitions:Intel Wireless WiFi 4965AGN (iwl4965) found in drivers/net/wireless/intel/iwlegacy/KconfigThe configuration item CONFIG_IWL4965:


intel now has their own app to do this in w7 its called My WiFi Dashboard & the wifi antennas supported are:Intel Centrino Advanced-N + WiMAX 6250Intel Centrino Advanced-N 6200Intel Centrino Advanced-N 6205Intel Centrino Advanced-N 6205 For DesktopIntel Centrino Advanced-N 6230Intel Centrino Advanced-N 6235Intel Centrino Ultimate-N 6300Intel Centrino Wireless-N + WiMAX 6150Intel Centrino Wireless-N 100Intel Centrino Wireless-N 1000Intel Centrino Wireless-N 1030Intel Centrino Wireless-N 105Intel Centrino Wireless-N 130Intel Centrino Wireless-N 135Intel Centrino Wireless-N 2200Intel Centrino Wireless-N 2200 For DesktopIntel Centrino Wireless-N 2230Intel My WiFi Technology (Intel MWT)Intel PRO/Wireless 3945ABG Network ConnectionIntel WiFi Link 1000Intel WiFi Link 5300 and Intel WiFi Link 5100 productsIntel WiMAX/WiFi Link 5350 and Intel WiMAX/WiFi Link 5150 productsIntel Wireless WiFi Link 4965AGN


So, one of the problems for gutsy->hardy upgraders may be that 2 drivers for 3945 are present. This may be a clue.BTW, I still get the "dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason" error.


> modinfo iwl3945filename: /lib/modules/2.6.24-19-generic/ubuntu/wireless/iwlwifi/iwlwifi/compatible/iwl3945.kolicense: GPLauthor: Copyright(c) 2003-2007 Intel Corporationversion: 1.2.0description: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linuxsrcversion: 8E95C617988943846696F97alias: pci:v00008086d00004227sv*sd*bc*sc*i*alias: pci:v00008086d00004222sv*sd*bc*sc*i*depends: iwlwifi_mac80211vermagic: 2.6.24-19-generic SMP mod_unload 586parm: antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)parm: disable:manually disable the radio (default 0 [radio on]) (int)parm: hwcrypto:using hardware crypto engine (default 0 [software]) (int)parm: debug:debug output mask (int)parm: disable_hw_scan:disable hardware scanning (default 0) (int)parm: queues_num:number of hw queues. (int)parm: qos_enable:enable all QoS functionality (int)


HiI've got an intel wireless card and have constant problems connecting like normal people. Just using netcfg2 or networkmanager is not possible. When I try connecting (after ifconfig wlan0 up) the iwl3945 driver goes up to 100% cpu load on one core. So I thought I try in single steps on the console. It is the following chip:


Ucode is installed btw (core/iwlwifi-3945-ucode 15.28.2.8-1). There are some other threads but nothing that fits exactly.One or two kernels ago I could switch it on and off and connect to whatever network I wanted. Any ideas on this?Thanks, David


>dmesg grep iwl3945iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ksiwl3945: Copyright(c) 2003-2009 Intel Corporationiwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17iwl3945 0000:03:00.0: setting latency timer to 64iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 0 802.11a channelsiwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945BGiwl3945 0000:03:00.0: irq 26 for MSI/MSI-Xiwl3945 0000:03:00.0: firmware: requesting iwlwifi-3945-2.ucodeiwl3945 0000:03:00.0: loaded firmware version 15.32.2.9


(12) alliance: >> dmesg egrep -i '(wlan03945)'iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ksiwl3945: Copyright(c) 2003-2009 Intel Corporationiwl3945 0000:06:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19iwl3945 0000:06:00.0: setting latency timer to 64iwl3945 0000:06:00.0: Tunable channels: 13 802.11bg, 23 802.11a channelsiwl3945 0000:06:00.0: Detected Intel Wireless WiFi Link 3945ABGiwl3945 0000:06:00.0: irq 29 for MSI/MSI-Xphy0: Selected rate control algorithm 'iwl-3945-rs'iwl3945 0000:06:00.0: firmware: requesting iwlwifi-3945-2.ucodeiwl3945 0000:06:00.0: loaded firmware version 15.32.2.9wlan0: authenticate with AP 00:1c:df:ce:5e:d6wlan0: authenticatedwlan0: associate with AP 00:1c:df:ce:5e:d6wlan0: RX AssocResp from 00:1c:df:ce:5e:d6 (capab=0x411 status=0 aid=1)wlan0: associated


Please be sure to check that you have the latest drivers installed for your wireless device by visiting the wireless card manufacturer's website or the computer manufacturer's website. Learn more about how to update your Wi-Fi drivers here: -how-to-update-your-wireless-wifi-driver.


  • OS version: JaS 10.4.8 ppf patched - select Intel SSE3, 10.4.4 login window app, GMA 950 drivers, powermgmt bundle

  • CPU: Celeron M 430 / 1.73 GHz (detected by CPU-Z as Yonah core) was advertised by Microcenter & on the box as a Celeron M 420, 1.6 GHz - got an extra 133 MHz for free!

  • detected as Core Solo in JaS 10.4.6 & Core Duo in JaS 10.4.8

  • MoBo chipset: Intel 945GM Express - all the basics like USB, SATA, keyboard, trackpad, etc. work fine

  • Video: GMA 950 - works like a charm (1280x800 on a 14.1" screen), minor color correction under pref panes

  • Sound: Realtek ALC883 - works after installing Azalia driver for 2-ch speaker out only Taruga's HDA driver adds more ports but doesn't play out the built-in speakers

  • Lan: Marvell Yukon 88E8038 - not working, though others have gotten it working on different laptops (???)

  • WiFi: Atheros AR5005G - working after some hacking in the terminal see/search forums

  • PCMCIA: Texas Instruments chipset PCIxx12 - working after installing hacked driver + glitchman 10.4.8 kexts see/search forums

  • 5-in-1 card reader: does not work, Windows device manager shows it as part of the PCMCIA chipset/interface

  • PowerManagement: works fine

  • Deep Sleep: like most hackintoshes, does not work (though someone claimed it working in 10.4.7 updated version)

  • Dual Boot: kinda tricky - work in progress (lots of guides available on this one)

  • Overall Impression: Can't beat the deal! Paid $450 and could get $50 back if I get around to mailing in the rebate. Everything either works fine out the box or can be gotten to work, except for built-in ethernet--but that can be gotten around by using a USB-to-ethernet adapter or probably PCMCIA card. Deep sleep is being worked on by others more technical than I. The laptop came with Vista basic, but ran like molasses. After installing Tiger x86, it pounces like a monster feline. Battery life seems to be about 3 hrs, depending on Energy Saver settings.

  • [edit] Aspire 3690 OS: JaS 10.4.8 SSE3 with (Jas Patch 10.4.8 from 10.4.6 Goat)

  • Intel Celeron M 1.73ghz (shows Intel core DUO), 512mb DDR2, 60GB ATA

  • Intel GMA 950 shared mem @ [email protected] QE/CI Working

  • Wi-Fi worked perfect (guide on insanelymac.com)

  • Sound Intel High definition audio worked (drivers and guide on insanelymac.com)

  • All USB + trackpad working

  • PowerBundle.kext to enable battery meter + management

  • Dual Boot OSX+XP using Darwin loader

  • Not working: 5in1 card reader (use XP to access)

  • [edit] Aspire Aspire 5100 AMD Turion 64x2OS: Uphuck 10.4.9 SSE3 universal kernal by semthex

  • Cpu works fine shows up as amd 1.6ghz

  • Ati express 1100 ( no QE/CI) but using katana/cilisto 003 its at [email protected])

  • Broadcom wireless (works just added line to plist)

  • Sound used acl883 drivers

  • keyboard mousepad work

  • Power management works but cpu runs at 1.6 ghz so battery life is killed in 1h 30 minz

  • 5 in 1 card reader non functional in osx

  • all usb working

  • when installing format partition make it mbr(win/dos machines) not gui( for intelmac) P.S if u install with gui partition ull after osx install it will boot to a black screen..

  • comp secs 2gb ddr2 ram 120ghz pata drive ati express 1100

  • Webcam not functional although osx did recognize it in System Profiler(need drivers)

[edit] Aspire 5101 ANWLMi AMD Turion 64 MK36 '''**** NOT WORKING **** INCORRECT INFORMATION GIVEN **** MUST INSTALL THROUGH VMWARE - BUT WILL NOT GO FURTHER THAN GREY SCREEN ****'''NOTE - Currently the latest disk with PPF1 and PPF2 will not detect the SATA HDD, so no install.


About

Welcome to the group! You can connect with other members, ge...
bottom of page